Overview
Users might encounter issues when Sococo is not starting your Sococo meeting or not turning on your microphone, video, or screen share. It is possible that the Sococo app is unable to detect your device and that is causing the issue. Error in Google Chrome console would be as follows:
ERROR [ChimeMediaManager] Fatal! Error while starting chime session TypeError: Cannot read property 'deviceId' of null
Diagnosis
It is possible that if you do not have one of the media devices connected, your meetings will not be able to start. You can check if Sococo can detect your devices by reviewing the Audio and Video settings for your application.
If any of the devices is not detected you will see an unpopulated (blank) list for that device, and it can cause the error and not start the meeting for you.
Solution
There are several steps you can take to ensure your device is connected properly and detected.
- If you do not have a microphone, speaker, or webcam connected, please connect them.
- If all devices are already connected, typically, unplugging and replugging the undetected hardware will register the device.
- Installing or reinstalling the drivers for the device.
- Restarting your computer.
If the issues are not solved by the steps above, you can follow the general steps below to identify where the issue is.
- Verify if the issue is with your computer or your device (microphone, speaker, webcam) by checking one of the following:
- connecting another device (mic, speaker, webcam) to your computer
- if it works fine, most likely your first device has a defect or drivers do not work.
- if it does not work, most likely your computer has issues with ports, Operating System, or drivers for the device.
- connecting the device to another computer
- if it works fine, most likely your computer has issues with ports, Operating System, or drivers for the device.
- if it does not work, most likely your device has a defect or drivers do not work.
- connecting another device (mic, speaker, webcam) to your computer
Steps on resolving the issue depend on what the issue is. Some of the possible solutions are:
- Identify the correct driver and install it.
- Replace your device (microphone, speakers, webcam).
- Reinstall your Operating System.
- Replace your computer.
Testing
Once the issue is resolved, and device is detected by the app, you will be able to select the device in Audio/Video Settings and start your meetings.
Related Articles
- Audio and Video Settings
- Media Usage Limit - Once you reach your Media Usage limit, you will not be able to start Sococo meetings, and you will get a notification that you have reached a limit.