Overview
There are several reasons why the Sococo Desktop application would need a reinstall. Perhaps the application is crashing with errors, not working properly, cannot start at all, or it just needs to be updated to the latest version.
Diagnosis
Some of the issues you may encounter with your Sococo desktop application that would require the full reinstall are:
- Microphone, camera, and screen sharing not working
- The desktop app not working correctly
- You are being logged off
- The desktop app not accepting the correct credentials
- Items in space displayed incorrectly
- Notifications not working as defined in settings
Before you begin the reinstallation process, make sure that the problems you are facing are related to the desktop application. To do that, try reproducing the issue using Sococo with the latest version of Chrome in Incognito mode. If you cannot reproduce the problem there, it means that the Sococo desktop app is causing the issues you have experienced.
Prerequisites
The reinstallation process requires administrative privileges for the Windows version of the desktop application.
Solution
If this is the case, you need to uninstall the app completely, clear the cache folders, and then install the latest version.
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Uninstall the Sococo application from your Windows or Mac PC.
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Clear the cache for the Sococo application by following the steps below:
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For Windows:
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Open the file explorer and manually enter the following path:
C:\Users\[your username]\AppData\
Notes:- AppData is a hidden folder, so it might not be displayed in the Explorer, but you can open it by adding
\AppData
to your path in the address bar. - In case your computer has multiple users, make sure you delete the listed folders for all of the users.
- AppData is a hidden folder, so it might not be displayed in the Explorer, but you can open it by adding
-
Search for the directories
Sococo
,SococoDev
,Sococo_RS
, andSococoDev_RS
in both the Local and the Roaming sub-folders. -
Delete the folders (if present).
-
-
For macOS:
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Open Finder and search for the
~/Library
directory.Note: If you cannot find the directory, navigate to Go > Go to Folder from Finder and search for~/Library
. -
Delete all the following directories (if present):
~/Library/Application Support/Sococo_RS
~/Library/Caches/*sococo
~/Library/Caches/Support/Sococo_R
-
-
-
Install the application (for Windows, with Admin privileges).
Testing
After the reinstall, the app should work without issues. Open the application and log in using your Sococo credentials.
If you are still facing issues, follow up on a Support ticket describing the issue in detail and all steps performed to resolve it.