Overview
Users on macOS might have issues with video, audio, and screen sharing if they did not allow the Sococo application to use the camera, microphone, and screen recording. The issue with users not being able to share the screen due to missing permissions is common after upgrading to the macOS Catalina. This article provides information on the root cause and the resolution of these issues.
Diagnosis
Depending on the Sococo version you are using, you might encounter these issues due to missing permissions (Privacy) for Sococo or Chrome. To be able to use Sococo, you need to approve the camera, microphone, and screen recording permissions. See the Resolution section for information on how to review and enable permissions.
Note: Screen recording permissions are needed for the macOS Catalina.
Solution
- Under System Preferences, click Security & Privacy.
- Under the Privacy tab, review the following permissions:
- Camera
- Microphone
- Screen Recording
If you are using the desktop app, make sure that you have checked the box to allow Sococo. If you are using the browser version, make sure that you have checked the box to allow Google Chrome.
Testing
After allowing the Sococo app to access your camera and microphone, and record your screen, you will be able to enable your media during a Sococo meeting. If the problem persists after the privacy settings have been updated: remove access permissions by unchecking Sococo and/or Google Chrome, restart the application, allow Sococo and/or Google Chrome to access the camera, microphone, and screen recording once again, and then restart the application again.